Ошибки Virtualbox

Содержание
Введение
your current centos software installation requires of available space
(rc=-1908) Kernel driver not installed
This system is currently not set up to build kernel modules
(rc=-1912) The VirtualBox kernel modules do not match this version of VirtualBox

Возможные проблемы

Если что-то не получилось, особенно в самом начале, например возникла ошибка 1908

Установка Virtual Windows 7 на Debian Linux изображение с сайта www.andreyolegovich.ru
rc=-1908
wwww.andreyolegovich.ru

и

Установка Virtual Windows 7 на Debian Linux изображение с сайта www.andreyolegovich.ru
rc=-1908
wwww.andreyolegovich.ru

Советую подумать:

Если все так - попробуйте сделать то, что советует virtualbox

/etc/init.d/vboxdrv setup

Однако, этого пути может и не существовать.

Есть форумы, где обсуждалась эта проблема - поyahooярьте, пояндексите. Правда, когда у меня на ноутбуке возникла такая проблема, ничего оттуда не помогло. Но у меня было старое ядро!

your current centos software installation requires of available space

При попытке установить новую вирутальную ОС может появиться следующая ошибка

virtualbox your current centos software installation requires of available space including for software and for swap space

Нажмите Reclaim Space

Создание host-only адаптера в VirtualBox изображение с сайта www.andreyolegovich.ru
reclaim space
ww.andreyolegovich.ru
Создание host-only адаптера в VirtualBox изображение с сайта www.andreyolegovich.ru
reclaim space
ww.andreyolegovich.ru

Kernel driver not installed (rc=-1908)

Довольно затруднительная ситуация когда при выполнении

virtualbox

Получаете предупреждение

WARNING: The character device /dev/vboxdrv does not exist. Please install the virtualbox-dkms package and the appropriate headers, most likely linux-headers-generic. You will not be able to start VMs until this problem is fixed.

А в UI следующая ошибка

Kernel driver not installed (rc 1908) в VirtualBox изображение с сайта www.andreyolegovich.ru
rc=-1908
ww.andreyolegovich.ru

Попытки установить всё перечисленное выше и сделать apt upgrade могут не принести результата

sudo apt install virtualbox-dkms

Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: libfprint-2-tod1 libllvm10 libllvm10:i386 linux-headers-5.4.0-59 linux-headers-5.4.0-59-generic linux-headers-5.6.0-1020-oem linux-headers-5.6.0-1036-oem linux-headers-5.6.0-1039-oem linux-image-5.4.0-59-generic linux-image-5.6.0-1020-oem linux-image-5.6.0-1036-oem linux-image-5.6.0-1039-oem linux-modules-5.4.0-59-generic linux-modules-5.6.0-1020-oem linux-modules-5.6.0-1036-oem linux-modules-5.6.0-1039-oem linux-modules-extra-5.4.0-59-generic linux-modules-nvidia-450-5.4.0-59-generic linux-oem-5.6-headers-5.6.0-1020 linux-oem-5.6-headers-5.6.0-1036 linux-oem-5.6-headers-5.6.0-1039 Use 'sudo apt autoremove' to remove them. The following additional packages will be installed: linux-headers-5.4.0-60 linux-headers-5.4.0-60-generic The following NEW packages will be installed: linux-headers-5.4.0-60 linux-headers-5.4.0-60-generic linux-headers-generic 0 upgraded, 3 newly installed, 0 to remove and 1 not upgraded. Need to get 12.2 MB of archives. After this operation, 85.4 MB of additional disk space will be used. Do you want to continue? [Y/n] Y Get:1 http://fi.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-60 all 5.4.0-60.67 [11.0 MB] Get:2 http://fi.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-60-generic amd64 5.4.0-60.67 [1,232 kB] Get:3 http://fi.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-generic amd64 5.4.0.60.63 [2,468 B] Fetched 12.2 MB in 2s (6,333 kB/s) Selecting previously unselected package linux-headers-5.4.0-60. (Reading database ... 382700 files and directories currently installed.) Preparing to unpack .../linux-headers-5.4.0-60_5.4.0-60.67_all.deb ... Progress: [ 8%] [#####.................................................................] Selecting previously unselected package linux-headers-5.4.0-60-generic..........................] Preparing to unpack .../linux-headers-5.4.0-60-generic_5.4.0-60.67_amd64.deb ... Unpacking linux-headers-5.4.0-60-generic (5.4.0-60.67) ... Selecting previously unselected package linux-headers-generic. Preparing to unpack .../linux-headers-generic_5.4.0.60.63_amd64.deb ... Unpacking linux-headers-generic (5.4.0.60.63) ... Setting up linux-headers-5.4.0-60 (5.4.0-60.67) ... Setting up linux-headers-5.4.0-60-generic (5.4.0-60.67) ... /etc/kernel/header_postinst.d/dkms: * dkms: running auto installation service for kernel 5.4.0-60-generic Kernel preparation unnecessary for this kernel. Skipping... applying patch disable_fstack-clash-protection_fcf-protection.patch...patching file Kbuild Hunk #1 succeeded at 84 (offset 13 lines). Building module: cleaning build area... unset ARCH; [ ! -h /usr/bin/cc ] && export CC=/usr/bin/gcc; env NV_VERBOSE=1 'make' -j8 NV_EXCLUDE_BUI LD_MODULES='' KERNEL_UNAME=5.4.0-60-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/mod Progress: [ 69%] [#######################################...........#####.........................] Signing module: - /var/lib/dkms/nvidia/450.80.02/5.4.0-60-generic/x86_64/module/nvidia-uvm.ko - /var/lib/dkms/nvidia/450.80.02/5.4.0-60-generic/x86_64/module/nvidia.ko - /var/lib/dkms/nvidia/450.80.02/5.4.0-60-generic/x86_64/module/nvidia-modeset.ko - /var/lib/dkms/nvidia/450.80.02/5.4.0-60-generic/x86_64/module/nvidia-drm.ko Nothing to do. cleaning build area... DKMS: build completed. nvidia.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ nvidia-modeset.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ nvidia-drm.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ nvidia-uvm.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ depmod... DKMS: install completed. Kernel preparation unnecessary for this kernel. Skipping... Building module: cleaning build area... make -j8 KERNELRELEASE=5.4.0-60-generic -C /lib/modules/5.4.0-60-generic/build M=/var/lib/dkms/virtual box/6.1.10/build...... Signing module: - /var/lib/dkms/virtualbox/6.1.10/5.4.0-60-generic/x86_64/module/vboxdrv.ko - /var/lib/dkms/virtualbox/6.1.10/5.4.0-60-generic/x86_64/module/vboxnetadp.ko - /var/lib/dkms/virtualbox/6.1.10/5.4.0-60-generic/x86_64/module/vboxnetflt.ko Nothing to do. cleaning build area... DKMS: build completed. vboxdrv.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ vboxnetadp.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ vboxnetflt.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/5.4.0-60-generic/updates/dkms/ depmod... DKMS: install completed. ...done. Setting up linux-headers-generic (5.4.0.60.63) ...

sudo modprobe vboxdrv

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.8.0-34-generic

sudo dpkg-reconfigure virtualbox-dkms

-------- Uninstall Beginning -------- Module: virtualbox Version: 6.1.10 Kernel: 5.4.0-60-generic (x86_64) ------------------------------------- Status: Before uninstall, this module version was ACTIVE on this kernel. vboxdrv.ko: - Uninstallation - Deleting from: /lib/modules/5.4.0-60-generic/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetadp.ko: - Uninstallation - Deleting from: /lib/modules/5.4.0-60-generic/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetflt.ko: - Uninstallation - Deleting from: /lib/modules/5.4.0-60-generic/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. depmod... DKMS: uninstall completed. -------- Uninstall Beginning -------- Module: virtualbox Version: 6.1.10 Kernel: 5.6.0-1036-oem (x86_64) ------------------------------------- Status: Before uninstall, this module version was ACTIVE on this kernel. vboxdrv.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1036-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetadp.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1036-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetflt.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1036-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. depmod... DKMS: uninstall completed. -------- Uninstall Beginning -------- Module: virtualbox Version: 6.1.10 Kernel: 5.6.0-1039-oem (x86_64) ------------------------------------- Status: Before uninstall, this module version was ACTIVE on this kernel. vboxdrv.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1039-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetadp.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1039-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetflt.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1039-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. depmod... DKMS: uninstall completed. -------- Uninstall Beginning -------- Module: virtualbox Version: 6.1.10 Kernel: 5.6.0-1042-oem (x86_64) ------------------------------------- Status: Before uninstall, this module version was ACTIVE on this kernel. vboxdrv.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1042-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetadp.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1042-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. vboxnetflt.ko: - Uninstallation - Deleting from: /lib/modules/5.6.0-1042-oem/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version. depmod... DKMS: uninstall completed. ------------------------------ Deleting module version: 6.1.10 completely from the DKMS tree. ------------------------------ Done. Loading new virtualbox-6.1.10 DKMS files... Building for 5.8.0-34-generic 5.8.0-36-generic Building initial module for 5.8.0-34-generic ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/virtualbox-dkms.0.crash' Error! Bad return status for module build on kernel: 5.8.0-34-generic (x86_64) Consult /var/lib/dkms/virtualbox/6.1.10/build/make.log for more information.

sudo dpkg-reconfigure virtualbox

Job for vboxweb.service failed because the service did not take the steps required by its unit configuration. See "systemctl status vboxweb.service" and "journalctl -xe" for details. Job for virtualbox.service failed because the control process exited with error code. See "systemctl status virtualbox.service" and "journalctl -xe" for details. invoke-rc.d: initscript virtualbox, action "restart" failed. virtualbox.service - LSB: VirtualBox Linux kernel module Loaded: loaded (/etc/init.d/virtualbox; generated) Active: failed (Result: exit-code) since Fri 2021-01-08 15:31:23 EET; 4ms ago Docs: man:systemd-sysv-generator(8) Process: 66734 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE) Jan 08 15:31:23 LL-USER2 systemd[1]: Starting LSB: VirtualBox Linux kernel module... Jan 08 15:31:23 LL-USER2 virtualbox[66734]: * Loading VirtualBox kernel modules... Jan 08 15:31:23 LL-USER2 virtualbox[66734]: * No suitable module for running kernel found Jan 08 15:31:23 LL-USER2 virtualbox[66734]: ...fail! Jan 08 15:31:23 LL-USER2 systemd[1]: virtualbox.service: Control process exited, code=exited, status=1/FAILURE Jan 08 15:31:23 LL-USER2 systemd[1]: virtualbox.service: Failed with result 'exit-code'. Jan 08 15:31:23 LL-USER2 systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.

Содержание man SYSTEMD-SYSV-GENERATOR (8)

SYSTEMD-SYSV-GENERATOR (8) systemd-sysv-generator S NAME systemd-sysv-generator - Unit generator for SysV init scripts SYNOPSIS /lib/systemd/system-generators/systemd-sysv-generator DESCRIPTION systemd-sysv-generator is a generator that creates wrapper .service units for SysV init[1] scripts in /etc/init.d/* at boot and when configuration of the system manager is reloaded. This will allow systemd(1) to support them similarly to native units. LSB headers[2] in SysV init scripts are interpreted, and the ordering specified in the header is turned into dependencies between the generated unit and other units. The LSB facilities "$remote_fs", "$network", "$named", "$portmap", "$time" are supported and will be turned into dependencies on specific native systemd targets. See systemd.special(7) for more details. SysV runlevels have corresponding systemd targets (runlevelX.target). The wrapper unit that is generated will be wanted by those targets which correspond to runlevels for which the script is enabled. systemd does not support SysV scripts as part of early boot, so all wrapper units are ordered after basic.target. systemd-sysv-generator implements systemd.generator(7). SEE ALSO systemd(1), systemd.service(5), systemd.target(5) NOTES 1. SysV init https://savannah.nongnu.org/projects/sysvinit 2. LSB headers http://refspecs.linuxbase.org/LSB_3.1.1/LSB-Core-generic/LSB-Core-generic/iniscrptact.html systemd 245 SYSTEMD-SYSV-GENERATOR(8)

sudo apt install --reinstall linux-headers-$(uname -r) virtualbox-dkms dkms

Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: libfprint-2-tod1 libllvm10 libllvm10:i386 linux-headers-5.4.0-59 linux-headers-5.4.0-59-generic linux-headers-5.6.0-1020-oem linux-headers-5.6.0-1036-oem linux-headers-5.6.0-1039-oem linux-image-5.4.0-59-generic linux-image-5.6.0-1020-oem linux-image-5.6.0-1036-oem linux-image-5.6.0-1039-oem linux-modules-5.4.0-59-generic linux-modules-5.6.0-1020-oem linux-modules-5.6.0-1036-oem linux-modules-5.6.0-1039-oem linux-modules-extra-5.4.0-59-generic linux-modules-nvidia-450-5.4.0-59-generic linux-oem-5.6-headers-5.6.0-1020 linux-oem-5.6-headers-5.6.0-1036 linux-oem-5.6-headers-5.6.0-1039 Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 3 reinstalled, 0 to remove and 1 not upgraded. Need to get 1,990 kB of archives. After this operation, 0 B of additional disk space will be used. Get:1 http://fi.archive.ubuntu.com/ubuntu focal/main amd64 dkms all 2.8.1-5ubuntu1 [66.6 kB] Get:2 http://fi.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.8.0-34-generic amd64 5.8.0-34.37~20.04.2 [1,236 kB] Get:3 http://fi.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-dkms amd64 6.1.10-dfsg-1~ubuntu1.20.04.1 [687 kB] Fetched 1,990 kB in 0s (7,308 kB/s) (Reading database ... 412468 files and directories currently installed.) Preparing to unpack .../dkms_2.8.1-5ubuntu1_all.deb ... Unpacking dkms (2.8.1-5ubuntu1) over (2.8.1-5ubuntu1) ... Preparing to unpack .../linux-headers-5.8.0-34-generic_5.8.0-34.37~20.04.2_amd64.deb ... Unpacking linux-headers-5.8.0-34-generic (5.8.0-34.37~20.04.2) over (5.8.0-34.37~20.04.2) ... Preparing to unpack .../virtualbox-dkms_6.1.10-dfsg-1~ubuntu1.20.04.1_amd64.deb ... ------------------------------ Deleting module version: 6.1.10 completely from the DKMS tree. ------------------------------ Done. Unpacking virtualbox-dkms (6.1.10-dfsg-1~ubuntu1.20.04.1) over (6.1.10-dfsg-1~ubuntu1.20.04.1) ... Setting up linux-headers-5.8.0-34-generic (5.8.0-34.37~20.04.2) ... /etc/kernel/header_postinst.d/dkms: * dkms: running auto installation service for kernel 5.8.0-34-generic ...done. Setting up dkms (2.8.1-5ubuntu1) ... Setting up virtualbox-dkms (6.1.10-dfsg-1~ubuntu1.20.04.1) ... Loading new virtualbox-6.1.10 DKMS files... Building for 5.8.0-34-generic 5.8.0-36-generic Building initial module for 5.8.0-34-generic ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/virtualbox-dkms.0.crash' Error! Bad return status for module build on kernel: 5.8.0-34-generic (x86_64) Consult /var/lib/dkms/virtualbox/6.1.10/build/make.log for more information. dpkg: error processing package virtualbox-dkms (--configure): installed virtualbox-dkms package post-installation script subprocess returned error exit status 10 Processing triggers for man-db (2.9.1-1) ... Errors were encountered while processing: virtualbox-dkms E: Sub-process /usr/bin/dpkg returned an error code (1)

This system is currently not set up to build kernel modules.

This system is currently not set up to build kernel modules. Please install the gcc make perl packages from your distribution. modprobe vboxguest failed The log file /var/log/vboxadd-setup.log may contain further information.

Установите gcc

В Rocky , CentOS и RedHat это делается следующим образом

yum install gcc

The VirtualBox kernel modules do not match this version of VirtualBox

RTR3InitEx failed with rc=-1912 (rc=-1912) The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing '/sbin/vboxconfig' may correct this. Make sure that you are not mixing builds of VirtualBox from different sources. where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.

Возможно, существует более цивилизованный способ решения этой проблемы, но мне приходится удалять текущий VirtualBox

sudo apt remove --purge virtualbox sudo apt install virtualbox

Иногда рекомендуют установить также virtualbox-dkms

sudo apt install virtualbox-dkms

Однажды мне помогло скачивание новой версии и устанавка из .deb

sudo dpkg -i virtualbox-6.1_6.1.28-147628\~Ubuntu\~eoan_amd64.deb

Похожие статьи
VirtualBox
Виртуальная CentOS 7 на Ubuntu
Терминал VirtualBox
Windows 7 на VirtualBox Debian
VBoxManage Manual
Разбор ошибок
DevOps
CentOS
Ubuntu

Поиск по сайту

Telegram канал чтобы следить за выходом новых статей

@aofeed

Задать вопрос в Телеграм-группе

@aofeedchat

IT

Актуально сейчас

Разное

Поиск по сайту

Telegram канал чтобы следить за выходом новых статей

@aofeed

Задать вопрос в Телеграм-группе

@aofeedchat

Контакты и сотрудничество:
Рекомендую наш хостинг beget.ru
Пишите на info@urn.su если Вы:
1. Хотите написать статью для нашего сайта или перевести статью на свой родной язык.
2. Хотите разместить на сайте рекламу, подходящуюю по тематике.
3. Реклама на моём сайте имеет максимальный уровень цензуры. Если Вы увидели рекламный блок недопустимый для просмотра детьми школьного возраста, вызывающий шок или вводящий в заблуждение - пожалуйста свяжитесь с нами по электронной почте
4. Нашли на сайте ошибку, неточности, баг и т.д. ... .......
5. Статьи можно расшарить в соцсетях, нажав на иконку сети: